$re = '/(?<=\.|\s|^)([a-z]{1,2}?)(?=\s|$|\.)/';
$str = 'yy y yy xxx-zz xx.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);