package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\b`)
var str = `block-name
block-name__elem
block-name_mod
block-name__elem_mod
block
block__elem
block_mod
block__elem_mod`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}