// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\b").unwrap();
let string = "block-name
block-name__elem
block-name_mod
block-name__elem_mod
block
block__elem
block_mod
block__elem_mod";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}