# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|[^ \/?$])\b(foo)\b"
test_str = ("foo - need this\n"
"<div>foo</div> - need this\n\n"
" foo - dont need this\n"
"Foo - dont need this\n"
"foobar - dont need this\n"
"/foo/ - dont need this")
subst = "$1bar"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.