// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|[^ \/?$])\b(foo)\b").unwrap();
let string = "foo - need this
<div>foo</div> - need this
foo - dont need this
Foo - dont need this
foobar - dont need this
/foo/ - dont need this";
let substitution = "$1bar";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}