const regex = /^(?!$)(?:<from>"([\d\-.]*)")?(?:<to>"([\d\-.]*)")?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!$)(?:<from>"([\\d\\-.]*)")?(?:<to>"([\\d\\-.]*)")?$', 'gm')
const str = `<from>"50"<to>""
<from>""<to>"60"
<from>"50"<to>"60"
<from>""<to>"60"
<to>"60"
<from>"50"
<to>"-5.5"<from>"-0.25"
9
""
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}