const regex = /^(?:([a-z]+-[a-z]+)|(\d+-\d+))$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([a-z]+-[a-z]+)|(\\d+-\\d+))$', 'gmi')
const str = `1
3
10-15
17
A
b
XX-YY
z
5-A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}