// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d(?:\.\d{1,4})?$").unwrap();
let string = "1
1.2
1.23
1.234
1.2345
These should fail.
10
10.1
1.23456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}