package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\bwith(.*?),`)
var str = `This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}