re = /(<span class='customer)(' id='phone\$1[^>]*>)([^<]+)/
str = 'GIVEN:
<div>
<span class=\'customer\' id=\'phone$0\'>Home</span>
<br/>
<span class=\'customer\' id=\'phone$1\'>Business</span>
<br/>
<span class=\'customer\' id=\'phone$2\'>Mobile</span>
</div>
DESIRED:
<span class=\'customer NewClass\' id=\'phone$1\'>Organization</span>
'
subst = '$1 NewClass$2Organization'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result