const regex = /(?:(^[1-9]\d*)(\.\d*[1-9])?|(^0)(\.\d*[1-9]))([eE][+-](?!0+$)\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(^[1-9]\\d*)(\\.\\d*[1-9])?|(^0)(\\.\\d*[1-9]))([eE][+-](?!0+$)\\d+)?$', 'gm')
const str = `123.4021203
0.11
00023123.1230000
0.101010101023e-124
010.000001
1230.123e+123
0.1e-1
1e-1
0e+2
0.e+2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}