$re = '/[A-Z][a-z]{3,4} ([0-9]{1,2}), [0-9]{4}/';
$str = 'Jan 5, 2011';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);