using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\(?(?:00|\+)?\d{3}\)?\s?\(?)?\d{7}\)?)";
string input = @"00965 3214576
* +965 3214576
* 009653214576
* +9653214576
* 3214576
* (+965)(3214576)
* (00965)(3214576)
* (+965) 3214576
* (00965) 3214576";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}