import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\(?(?:00|\\+)?\\d{3}\\)?\\s?\\(?)?\\d{7}\\)?)";
final String string = "00965 3214576 \n"
+ "* +965 3214576\n"
+ "* 009653214576\n"
+ "* +9653214576\n"
+ "* 3214576\n"
+ "* (+965)(3214576)\n"
+ "* (00965)(3214576)\n"
+ "* (+965) 3214576\n"
+ "* (00965) 3214576";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}