$re = '/((?:\(?(?:00|\+)?\d{3}\)?\s?\(?)?\d{7}\)?)/';
$str = '00965 3214576
* +965 3214576
* 009653214576
* +9653214576
* 3214576
* (+965)(3214576)
* (00965)(3214576)
* (+965) 3214576
* (00965) 3214576';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);