// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\/([a-z]+(?:-[a-z]+)*-[0-9]+)(?:\/|$)").unwrap();
let string = "http://example.com/somepath/this-is-composed-of-hypens-3144/someotherpath";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}