$re = '/(.+)(\|)(.+)(\|)(.+)/m';
$str = 'PR.CS|12|CS';
$subst = "$1$3$4$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;