use strict;
my $str = 'NOI - CSN - Riata Unit 5C - elec. - Fuquay - TXR150022379.pdf';
my $regex = qr/(?i)(?:noi)(?<space>(?:.*-.*))(?:csn\k<space>)?(?<noiNum>(?:txr12\w{3}f)|(?:txr15\d{7}))?(?:\k<space>)?(?<projName>(?:\b[\w\s\-\&]+?\b))(?:\k<space>).*?(?<noiNum2>(?:(?:trx12\w{3}f)|(?:txr15\d{7})))?(?:\.pdf)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}