// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:noi)(?<space>(?:.*-.*))(?:csn\k<space>)?(?<noiNum>(?:txr12\w{3}f)|(?:txr15\d{7}))?(?:\k<space>)?(?<projName>(?:\b[\w\s\-\&]+?\b))(?:\k<space>).*?(?<noiNum2>(?:(?:trx12\w{3}f)|(?:txr15\d{7})))?(?:\.pdf)$").unwrap();
let string = "NOI - CSN - Riata Unit 5C - elec. - Fuquay - TXR150022379.pdf";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}