# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G(\S+)( (?=\1(?: |\z)))?/hello$2/g;t' <<< "abc abc abc defg abc h abc abc abc"