// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([_-]?[a-z][_-]?[1-9][_-]?[a-z][_-]?)").unwrap();
let string = "
2222ab4053bcd4324abcd8877
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}