using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=(['""])(https?:\/\/[^ >]*?youtu\.?be[^ >]+?)(?=\1)";
string substitution = @"src=\1\2?wmode=transparent";
string input = @"<iframe width=""425"" height=""349"" src=""http://www.youtube.com/embed/8tPnX7OPo0Q"" frameborder=""0"" allowfullscreen></iframe>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}