use strict;
my $str = '<iframe width="425" height="349" src="http://www.youtube.com/embed/8tPnX7OPo0Q" frameborder="0" allowfullscreen></iframe>';
my $regex = qr/src=(['"])(https?:\/\/[^ >]*?youtu\.?be[^ >]+?)(?=\1)/p;
my $subst = 'src=\\1\\2?wmode=transparent';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";