# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"src=(['\"])(https?:\/\/[^ >]*?youtu\.?be[^ >]+?)(?=\1)"
test_str = "<iframe width=\"425\" height=\"349\" src=\"http://www.youtube.com/embed/8tPnX7OPo0Q\" frameborder=\"0\" allowfullscreen></iframe>"
subst = "src=\\1\\2?wmode=transparent"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.