import Foundation
let pattern = #"src=(['"])(https?:\/\/[^ >]*?youtu\.?be[^ >]+?)(?=\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<iframe width="425" height="349" src="http://www.youtube.com/embed/8tPnX7OPo0Q" frameborder="0" allowfullscreen></iframe>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"src=\1\2?wmode=transparent"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}