# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(?<=<h1\s+class=['\"\"]mb-0\s+mb-lg-1\s+svelte-jcq9ad['\"\"]\s*>)(.*?)(?=</\s*h1)"
test_str = ("<div>\n"
" <h1 class=\"mb-0 mb-lg-1 svelte-jcq9ad\">AdBlock — best ad blocker</h1>\n"
" <h2 class=\"mb-2 svelte-jcq9ad\">Block ads and pop-ups on YouTube, Facebook, Twitch, and your favorite websites.</h2>\n"
" </div>\n"
"</div>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.