$re = '/^([^,]*,(\d\d)_[^,]*,[^,]*)(?<!_\d\d),/ms';
$str = 'test,12_blah,blubb,anything
test,34_blah,blu_34,doesn\'t matter
test,56_foo,bar,nevermind';
$subst = "$1_$2,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;