const regex = /[ ]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ ]+', 'gm')
const str = `123456789
12 345 6789
123456789
12 345 6789
0 12 345 6789
0123456789
012 345 6789
0123456789`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);