$re = '/[ ]+/m';
$str = '123456789
 12 345 6789
123456789
 12 345 6789
 0 12 345 6789
0123456789
012 345 6789
0123456789';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;