// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[ ]+").unwrap();
let string = "123456789
12 345 6789
123456789
12 345 6789
0 12 345 6789
0123456789
012 345 6789
0123456789";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}