re = /\"[^""\r\n\\]*(?:"".[^""\r\n\\]*)*\"/mi
str = 'hola "soy "" un tio "pepiño"
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result