Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^raw_data\.(?!((event_record_string|event_record_binary|event_record_binary\.event_record_binary)\.prod\.(18477|18478|5416|5454|5455)|storage\.aw|codo)\.)(?!.*(failure_permanent|failure_\d+_\w+)$).*
/
Input 1
1
New
raw_data.foo.bar