import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\\">(.*?)<\\/td>";
final String string = "<tr>\\r\\n\\t\\t<td class=\\\"printCell\\\">NOLES A/S</td><td class=\\\"printCell\\\">Plast, glas og beton</td><td class=\\\"printCell\\\">Grøn</td><td class=\\\"printCell\\\" align=\\\"center\\\">13-04-2012</td><td class=\\\"printCell\\\" align=\\\"center\\\"> </td>\\r\\n\\t</tr>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}