// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\\">(.*?)<\/td>"#).unwrap();
let string = "<tr>\\r\\n\\t\\t<td class=\\\"printCell\\\">NOLES A/S</td><td class=\\\"printCell\\\">Plast, glas og beton</td><td class=\\\"printCell\\\">Grøn</td><td class=\\\"printCell\\\" align=\\\"center\\\">13-04-2012</td><td class=\\\"printCell\\\" align=\\\"center\\\"> </td>\\r\\n\\t</tr>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}