#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^#+ )[^\[]*?\[\[Wikilink]\][^\n]*?\n([\S\s]*?)(?1)"
Local $sString = "# Part 1" & @CRLF & _
"" & @CRLF & _
"## Some title 1 [[Wikilink]]" & @CRLF & _
"" & @CRLF & _
"Some" & @CRLF & _
"random" & @CRLF & _
"content" & @CRLF & _
"" & @CRLF & _
"### Sub title 1" & @CRLF & _
"" & @CRLF & _
"Content" & @CRLF & _
"" & @CRLF & _
"### Sub item 2" & @CRLF & _
"" & @CRLF & _
"Content" & @CRLF & _
"" & @CRLF & _
"## Other title 2" & @CRLF & _
"" & @CRLF & _
"Content" & @CRLF & _
"" & @CRLF & _
"# Part 2" & @CRLF & _
"" & @CRLF & _
"## title " & @CRLF & _
"" & @CRLF & _
"### Sub item [[Wikilink]]" & @CRLF & _
"" & @CRLF & _
"content here" & @CRLF & _
"" & @CRLF & _
"## title" & @CRLF & _
"" & @CRLF & _
"# Part 3 [[Wikilink]]" & @CRLF & _
"" & @CRLF & _
"content"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")