# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/\\/.*(*SKIP)(*FAIL)|("[^"]+")/<span class="red">$1<\/span>/gm;t' <<< "// eehen nhdhdhd ooe \"jjejej\" ejeje \"keihjen\" jehhemm
jejej \"jejeooe\" kekek \"jilnana\" jennbeb"