using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/\/.*(*SKIP)(*FAIL)|(""[^""]+"")";
string substitution = @"<span class=""red"">$1</span>";
string input = @"// eehen nhdhdhd ooe ""jjejej"" ejeje ""keihjen"" jehhemm
jejej ""jejeooe"" kekek ""jilnana"" jennbeb";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}