// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\/\/.*(*SKIP)(*FAIL)|("[^"]+")"#).unwrap();
let string = "// eehen nhdhdhd ooe \"jjejej\" ejeje \"keihjen\" jehhemm
jejej \"jejeooe\" kekek \"jilnana\" jennbeb";
let substitution = "<span class=\"red\">$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}