use strict;
my $str = 'import React from \'react\'
class Page extends React.Component {
static async getInitialProps(ctx) {
const res = await fetch(\'https://api.github.com/repos/zeit/next.js\')
const json = await res.json()
dispatchEvent(event)
return { stars: json.stargazers_count }
}
render() {
return <div>Next stars: {this.props.stars}</div>
}
}
export default Page
class Page extends React.Component {
static async getInitialProps(ctx) {
const res = await fetch(\'https://api.github.com/repos/zeit/next.js\')
const json = await res.json()
return { stars: json.stargazers_count }
}
render() {
return <div>Next stars: {this.props.stars}</div>
}
}';
my $regex = qr/^.*getInitialProps[\s\S]*?\bdispatch[\s\S]*?(return).*\n.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}