re = /(.+?)\[/
str = 'Word1 Word2 word3 [some words in brackets]
Word1 [some words in brackets]
word1, Word2 [some words in brackets]
'
subst = '%htmltag%\\1%/htmltag%['
result = str.gsub(re, subst)
# Print the result of the substitution
puts result