import re
regex = re.compile(r"^(ssh-rsa) (?!toto)")
test_str = "ssh-rsa"
subst = "\\1 tata"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)