#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza"
Local $sString = "Heloo my name is abcd, and I like pizza" & @CRLF & _
"Hello my name is asdf, and I like pizza" & @CRLF & _
"Hello my name is john, and I like pizza"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")