using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza";
string input = @"Heloo my name is abcd, and I like pizza
Hello my name is asdf, and I like pizza
Hello my name is john, and I like pizza";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}