import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza";
final String string = "Heloo my name is abcd, and I like pizza\n"
+ "Hello my name is asdf, and I like pizza\n"
+ "Hello my name is john, and I like pizza";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}