const regex = /Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza', 'gm')
const str = `Heloo my name is abcd, and I like pizza
Hello my name is asdf, and I like pizza
Hello my name is john, and I like pizza`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}