re = /Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza/m
str = 'Heloo my name is abcd, and I like pizza
Hello my name is asdf, and I like pizza
Hello my name is john, and I like pizza'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end