// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza").unwrap();
let string = "Heloo my name is abcd, and I like pizza
Hello my name is asdf, and I like pizza
Hello my name is john, and I like pizza";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}