$re = '/^([^t]*(?:t(?!able)[^t]*)*)(?:table)?$/m';
$str = 'diningtable
cookingtable
cooking
table
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);