using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"lat\W+()(?=\d+\W+\d+\W+\d+.\d+)";
string input = @"[231] ""Lat.41 41' 19.09\"" Long.-75 55' 19.51\""
[232] ""Lat. 41-41-22.13 Long. -75-59-17.29"" ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}