# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"lat\W+()(?=\d+\W+\d+\W+\d+.\d+)"
test_str = ("[231] \"Lat.41 41' 19.09\\\" Long.-75 55' 19.51\\\"\" \n"
"[232] \"Lat. 41-41-22.13 Long. -75-59-17.29\" ")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.